Skip to content

Eesti ID-kaardi tarkvara ehk open-eid v. 21.02 kasutamine Debian Bullseyes

Debian 11 ehk Bullseye külmutamisprotsess on piisavalt kaugel ning suuri muutusi enam ei tule ning ilmselt saavad ID-kaardi huvilised kasutada järgmist loogikat tarkvara paigaldamiseks.

Debianis teatavasti on võimalik kasutada Ubuntu jaoks mõeldud ID-kaardi tarkvara. Kuna nende kahe distro arendusprotsess on natuke nihkes, siis alati üks-ühele paigaldamine ei õnnestu. Nii on länud ka seekord - vajalik libxalan-c111 ei ole Bullseye's saadaval. Üldjoontes on kaks võimalust:

1) sul on kasutusel endine Buster, millele oled teinud distro-upgrade ning orphaner'iga pole seda üle käinud, siis on ta sul olemas, aga igaks juhuks vaata üle:

dpkg -l libxalan-c111 | grep libxalan-c111
ii libxalan-c111:amd64 1.11-9 amd64 XSLT processor library for C++

2) sul on puhas Bullseye või testing'u paigaldus, siis pead ta lisama näiteks Buster'ist

cd /tmp
wget http://ftp.ee.debian.org/debian/pool/main/x/xalan/libxalan-c111_1.11-9_amd64.deb
dpkg -i libxalan-c111_1.11-9_amd64.deb

Aga open-eid paigaldamine on olemuselt sama kui eelmisel korral:

wget -O /tmp/ria-public-2016.key https://installer.id.ee/media/install-scripts/C6C83D68.pub
apt-key add /tmp/ria-public-2016.key
echo '# open-eid ehk id-kaardi tarkvara' >> /etc/apt/sources.list
echo 'deb https://installer.id.ee/media/ubuntu/ focal main' >> /etc/apt/sources.list
apt update
apt install open-eid

Kuna apt-key kasutamine senines vormis lõppeb alates Debian 12'st, siis tekib võtme lisamisel hoiatus, kuid lisamine ise toimib.

Busterist üle kolides lihtsalt muuda repositoorium bionic'ust focal'iks ning tee:

apt update && apt upgrade

Varasemad artiklid id-kaardi tarkvara paigaldusest:

Trackbacks

No Trackbacks

Comments

Display comments as Linear | Threaded

Nimi on :

LMDE 4 (buster vist)ei saa hakkama selle õpetusega.
Oskad aidata?

The following packages have unmet dependencies:
open-eid : Depends: chrome-token-signing but it is not going to be installed
Depends: firefox-pkcs11-loader but it is not going to be installed
Depends: qdigidoc4 but it is not going to be installed
Recommends: libdigidocpp-tools but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


Kui ma üritan neid paigaldada, siis tulevad järgmised sõltuvad paketid mida isegi pole võimalik peale lasta ja räägib jälle midagi katkistest pakettidest.

Selle ühe näruse id kaardi pärast pean siiani ubuntul istuma. :-|

PJ on :

LMDE4 (Linux Mint Debian Edition) peaks põhinema Debian Busteril ja tema jaoks võib toimida see juhend:
https://priit.joeruut.com/archives/Eesti-ID-kaardi-tarkvara-ehk-open-eid-v.-20.01-kasutamine-Debianis.html. Ise testinud ei ole ja tegelikku toimivust kinnitada ei oska.

Jaan Juurikas on :

Bullseye osa abil sain ka Chromebookile ID-kaardi tarkvara paigaldatud

Add Comment

Enclosing asterisks marks text as bold (*word*), underscore are made via _word_.
Standard emoticons like :-) and ;-) are converted to images.
E-Mail addresses will not be displayed and will only be used for E-Mail notifications.

To prevent automated Bots from commentspamming, please enter the string you see in the image below in the appropriate input box. Your comment will only be submitted if the strings match. Please ensure that your browser supports and accepts cookies, or your comment cannot be verified correctly.
CAPTCHA 1CAPTCHA 2CAPTCHA 3CAPTCHA 4CAPTCHA 5


Form options